مجید

مشکل در وب سرویس لینوکسی

سلام . یک وب سرویس لینوکسی دارم که وقتی از یک سیستم DNS یا ip رو میزنم باز نمیشه . اما وقتی یک بار سرور رو ping میگیرم و دوباره امتحان میکنم ، سایت باز میشه . این مشکل فقط توی سیستم هایی هست که با سرور توی یک vlan هستند و در سیستم هایی که vlan متفاوتی دارند این مشکل وجود نداره . از دوستان tosiniso کسی میتونه کمکم کنه تا مشکل پیدا بشه ؟

این سوال 1 پاسخ دارد.
#وب_سرویس #فایروال #لینوکس
لذت یادگیری با توسینسو
به عنوان شخصی که مدت هاست از سایت توسینسو استفاده می کنم باید بگم که واقعاً یکی از بهترین مرجع ها برای ارتقاء دانش شخصی هست. دوره های سایت، راهکارها و مطالب، همگی عالی هستند.

سلام ، اطلاعاتی که دادین اصلا کافی نیست و اینجوری ما نمیتونیم کمکتون کنیم.

لطفا بفرمایید از چه توزیعی از لینوکس دارید استفاده می کنید ؟

چه وب سروری روی لینوکس نصب کردین ؟ Apache یا Nginx ؟

AMIRHOSSEIN KARIMPOUR
مجید

از دو تا centos استفاده میکنم یکی برای سرویس وب که Appache هست . یکی هم برای دیتا بیس که mysql هست .

نسخه CentOS چند هست ؟

AMIRHOSSEIN KARIMPOUR
مجید

CentOS Linux 7 (Core)- Kernel: Linux 3.10.0-693.17.1.el7.x86_64

هنوز راه زیادی رو برای Troubleshooting پیش رو دارید. kernel-3.10.0-693.17.1.el7.x86_64 برای نسخه 7.4 بود نسخه فعلی 7.6 هست. دستور yum update رو اجرا کنید تا سیستم آپدیت بشه. به سئوالات زیر هم لطفا جواب بدید :

  1. سیستم چطوری به شبکه وصل شده ؟ از DHCP آدرس IP میگیره یا بصورت Static روش IP ست شده ؟
  2. روی چه سیستمی مرورگر رو باز می کنید ؟ روی وب سرور یا روی سیستم های کلاینت ؟
  3. کلاینت و وب سرور و سرور دیتابیس به یک سوئیچ شبکه وصل شدن ؟
  4. مطمئن هستید Duplicate IP توی شبکه ندارین ؟
AMIRHOSSEIN KARIMPOUR
مجید

1) آی پی به صورت استایتک set شده

2) روی سیستم کلاینت ها این مشکل وجود داره .فقط کلاینت های هم رنج با سرور که در واقع با سرور درون یک vlan هستند و روی بقیه کلاینت ها این مشکل نیست

3) همگی به یک سوئیچ وصل نیستند . هم فیزیکی و هم مجازی هستند .

4) بله

با تمام مرورگر ها این مشکل وجود داره .فایروال سرور رو هم خاموش کردم اما تاثیری نداشت .

همگی به یک سوئیچ وصل نیستند . هم فیزیکی و هم مجازی هستند . منظورم این هست که کلاینت ها و سرور ها به یک سوئیچ فیزیکی وصل هستند ؟ فارغ از بحث مجازی سازی و VLAN و ...

AMIRHOSSEIN KARIMPOUR
مجید

نه . به سوئیچ های مختلف وصل هستند . سوئیچ های cisco 2960

به احتمال زیاد مشکل ARP دارید. ARP Table کلاینت و سرور رو چک کنید.

سیستم عامل کلاینتی که این مشکل رو داره چیه ؟

AMIRHOSSEIN KARIMPOUR
مجید

کلاینت ها ویندوز سرور 2003 ، 2008 ، 2012 و 2016 هستند و با همشون چک کردم مشکل وجود داره . روی arp table مک آدرس وجود دارد و بعد از ping گرفتن هم همان مک وجود دارد . مطمئن هستم که هر مشکلی هست سمت سرور لینوکسی هست .

پس احتمالا مشکل از سوئیچتون هست. خروجی دستور زیر رو اینجا قرار بدید ( لطفا در قالب کد ( از کلید های ترکیبی Ctrl+K استفاده کنید ) ارسال کنید ) :

$ cat /etc/sysconfig/network-scripts/ifcfg-$interface

دقت کنید که خروجی مربوط به Connection ای که به وب سرور مربوط هست رو ارسال کنید.

AMIRHOSSEIN KARIMPOUR
مجید
HWADDR=00:50:56:A6:0F:0C
TYPE=Ethernet
PROXY_METHOD=none
BROWSER_ONLY=no
BOOTPROTO=none
IPADDR=10.10.10.166
PREFIX=32
GATEWAY=10.10.10.1
DNS1=10.10.10.7
DEFROUTE=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_FAILURE_FATAL=no
IPV6_ADDR_GEN_MODE=stable-privacy
NAME="Wired connection 2"
UUID=c8df1dfd-4cdd-34de-9d6e-5c1e4abc4e51
ONBOOT=yes
AUTOCONNECT_PRIORITY=-999
DNS2=10.10.10.5

PREFIX رو اشتباه تنظیم کردید !! نباید 32 باشه PREFIX ، باید 24 بزاریدش. با NETMASK 255.255.255.255 فقط میتونید خود آدرس IP سیستم رو ببینید و Gateway رو دیگه نمیتونید ببینید.

AMIRHOSSEIN KARIMPOUR
  • انتخاب شده به عنوان جواب توسط 1 نفر
پاسخ شما
برای ارسال پاسخ خود وارد شوید.
از سرتاسر توسینسو
تنظیمات حریم خصوصی
تائید صرفنظر
×

تو می تونی بهترین نتیجه رو تضمینی با بهترین های ایران بدست بیاری ، پس مقایسه کن و بعد خرید کن : فقط توی جشنواره تابستانه می تونی امروز ارزونتر از فردا خرید کنی ....