علی محمدی

مشکل عجیب SSH

سلام خدمت تک تک کاربران توسینسویی .
سرویس SSH به درستی کار نمیکرد ، حتی نمیتونستم به سیستم خودم ssh بکنم :
[ali@arch ~]$ ssh ali@localhost

ssh: connect to host localhost port 22: Connection refused
تصمیم گرفتم که پورت رو عوض کنم داخل فایل etcssh/ssh_config شدم و خط مربوط به Port 22 رو انکامنت و به 2222 تغییر دادم و سرویس sshd رو ریستارت کردم و مجدد تست کردم اما بی فایده بود .
مجدد تمام تنظیمات رو به حالت اول برگردوندم و دوباره سرویس رو ریستارت کردم ایندفعه جواب گرفت و ssh موفق بود ، حالا سوالی که برام پیش اومد این هست که چطور وصل شد !؟ پورت SSH روی روتر هم بسته هست اما دستور netstat چیز دیگه رو میگه :
[ali@arch ~]$ netstat state ESTABLISHED -pn | grep -i ssh
tcp        0      0 192.168.1.4:60970       192.168.1.2:8022        ESTABLISHED 4552/ssh            
tcp        0      0 192.168.1.4:32900       192.168.1.7:22          ESTABLISHED 4623/ssh
ای پی 192.168.1.7 مربوط به ماشین مجازی من هست که نشون میده روی پورت 22 متصل شده که از DHCP روتر ای پی میگیره .
ای پی 192.168.1.2 مربوط به ترموکس هست که روی پورت 8022 بهش متصل شدم .
من از ارچ استفاده میکنم و فایروالی به صورت پیشفرض نصب نیست الا iptable که اون هم کلا خاموشه :
[ali@arch ~]$ systemctl status iptables.service 
● iptables.service - IPv4 Packet Filtering Framework
   Loaded: loaded (/usr/lib/systemd/system/iptables.service; disabled; vendor preset: disabled)
   Active: inactive (dead)
خوب وقتی پورتی باز نیست این به چه شکل داره کار میکنه و چرا الان میتونه کانکت بشه !؟
لذت یادگیری با توسینسو
به عنوان شخصی که مدت هاست از سایت توسینسو استفاده می کنم باید بگم که واقعاً یکی از بهترین مرجع ها برای ارتقاء دانش شخصی هست. دوره های سایت، راهکارها و مطالب، همگی عالی هستند.
سلام دوست عزیز
من متوجه سوال شما نشدم به صورت کامل ولی یک نکته ای وجود داره که البته شاید شما در زمان تایپ بهش دقت نکرده باشید و اون هم این مطلب است که باید به جای فایل etcsshsshconfig فایل etcsshsshdconfig رو تغییر بدین تا تغییرات اعمال بشه.

همه با هم در جهت افزایش سطح دانش
سلام ، اگه باز هم جواب نگرفتید دستورات زیر رو اجرا کنید :
$ sudo apt-get remove openssh-client openssh-server
$ sudo apt-get install openssh-client openssh-server
AMIRHOSSEIN KARIMPOUR
پاسخ شما
برای ارسال پاسخ خود وارد شوید.
تنظیمات حریم خصوصی
تائید صرفنظر

امروز ارزان تر از فردا در جشنواره تخفیف ها

با بهترین ها یاد بگیرید