kian2019

کار نکردن sudo apt-get

سلام
هر نرم افزاری که میخوام با sudo apt-get نصب کنم برای مثال نصب این مورد sudo apt-get install jcal که این پیام رومیده

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 google-chrome-stable : Depends: libappindicator3-1 but it is not going to be installed
 jcal : Depends: libjalali0 but it is not going to be installed
 skypeforlinux : Depends: gconf-service but it is not going to be installed
                 Depends: libgconf-2-4 (>= 3.2.5) but it is not going to be installed
 teamviewer : Depends: libqt5x11extras5 (>= 5.5) but it is not going to be installed or
                       qt56-teamviewer but it is not installable
              Depends: qml-module-qtquick2 (>= 5.5) but it is not going to be installed or
                       qt56-teamviewer but it is not installable
              Depends: qml-module-qtquick-controls (>= 5.5) but it is not going to be installed or
                       qt56-teamviewer but it is not installable
              Depends: qml-module-qtquick-dialogs (>= 5.5) but it is not going to be installed or
                       qt56-teamviewer but it is not installable
              Depends: qml-module-qtquick-window2 (>= 5.5) but it is not going to be installed or
                       qt56-teamviewer but it is not installable
              Depends: qml-module-qtquick-layouts (>= 5.5) but it is not going to be installed or
                       qt56-teamviewer but it is not installable
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution)

لطفا راهنمایی کنید

این سوال 2 پاسخ دارد.
لذت یادگیری با توسینسو
به عنوان شخصی که مدت هاست از سایت توسینسو استفاده می کنم باید بگم که واقعاً یکی از بهترین مرجع ها برای ارتقاء دانش شخصی هست. دوره های سایت، راهکارها و مطالب، همگی عالی هستند.
iman-239
سلام این چندتا کار رو امتحان کن

بروزرسانی مخازن با apt-get update

همونطور که در ارور ها هست نصب بسته مورد نظرت با
apt --fix-broken install


  • انتخاب شده به عنوان جواب توسط 1 نفر
سلام ، دستور زیر رو اجرا کنید تا به سیستم بگید به صورت Force فایل هایی رو که قبلا Load نشدن و روی سیستم وجود ندارن رو نصب کنه :
$ sudo apt-get -f install
حالا دستور زیر رو اجرا کنید تا نسخه ی بسته ها با Repository هماهنگ سازی بشه :
$ sudo apt-get update
حالا مجددا دستور زیر رو اجرا کنید :
$ sudo apt-get -f install
حالا دستور زیر رو اجرا کنید :
$ sudo dpkg --configure -a
در آخر هم کش apt رو Clean کنید :
$ sudo apt-get clean
AMIRHOSSEIN KARIMPOUR
  • انتخاب شده به عنوان جواب توسط 1 نفر
kian2019
خیل ممنون درست شد

پاسخ شما
برای ارسال پاسخ خود وارد شوید.
تنظیمات حریم خصوصی
تائید صرفنظر

امروز ارزان تر از فردا در جشنواره تخفیف ها

با بهترین ها یاد بگیرید